sqeak in front end?

Discussion in '1998 - 2011 Ford Ranger' started by scott5640, Aug 30, 2012.

  1. scott5640

    scott5640 EdgeRunner

    every time i go over bumps or potholes my front right control arm area sqeaks..ive tried putting wd-40 on all the bushings but it still does it what could it be?
  2. Ranger Forum Sign Up!

    Join RangerForum.com Today - It's Totally Free!

    Are you a Ford Ranger fan? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Ford Ranger Fans to meet online.
    Once you join you'll be able to post messages, upload pictures of your Ford, and have a great time with other Ranger fans. Whether your an old timer or just bought your Ford you'll find that Ranger Forum is a great community to join. Best of all it's totally free!

    Join RnagerForum.com Today! JOIN FOR FREE

  3. front shocks , mine used to do it too
  4. OP

    scott5640 EdgeRunner

    i sprayed them with wd 40 and bounced the front end...still do it
  5. Brinker88

    Brinker88 Black sheep o' the family

    Bolts inside the steel sleeve of the bushing. Use penetrating lube (PB Blaster) and hit them multiple times. Should work.

    Might also be your sway bar bushings at the frame.
  6. OP

    scott5640 EdgeRunner

    i sprayed everything and still sqeaks
  7. Hurley

    Hurley Superultramegalurker

    Wd-40 sucks use pb blaster. I had a pretty mean squeek when my ball joints went bad

Share This Page