Popping noise when in 4wheel

Discussion in '1998 - 2011 Ford Ranger' started by rangerguy95, Apr 11, 2013.

  1. rangerguy95

    rangerguy95 New Member

    I got my rugged ridge locking hubs in now so I have 4wheel again but now when i engage, ill drive a little bit and there will be popping noises coming from the front axle area, im thinking maybe front driveshaft, since when i put it in the ball end that goes in the tcase had a dent in it, any other thoughts?
  2. Ranger Forum Sign Up!

    Join RangerForum.com Today - It's Totally Free!

    Are you a Ford Ranger fan? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Ford Ranger Fans to meet online.
    Once you join you'll be able to post messages, upload pictures of your Ford, and have a great time with other Ranger fans. Whether your an old timer or just bought your Ford you'll find that Ranger Forum is a great community to join. Best of all it's totally free!

    Join RnagerForum.com Today! JOIN FOR FREE

  3. 06FordFX4

    06FordFX4 Canadian Redneck

    are you on pavement when you do this? because it will bind and pop unless you are on a slippery enough surface to allow the front or rear to slip a little.
  4. OP

    rangerguy95 New Member

    I am, but I don't think it should be this bad from pavement alone, cuz im not going road speeds im just crawling along to test and it pops alot, but i can go test it in sugar sand right now and find out
  5. 06FordFX4

    06FordFX4 Canadian Redneck

    It will be bad on pavement lol.
    Never use 4x4 on hard surfaces.
  6. OP

    rangerguy95 New Member

    just went out and tried it, still pops and bangs and all sorts of no-no noises. I dont think the fronts are grabbing either but idk its dark out atm haha

Share This Page