Intermittent problem with cab light, power windows, wipers!

Discussion in '1998 - 2011 Ford Ranger' started by Chuck Moore, Apr 22, 2017.

  1. Chuck Moore

    Chuck Moore New Member

    Hi, well I am totally flummoxed. I have a 2WD 1998 Side step Ranger. History: Purchased used! Found water inside the cab after a heavy rainstorm. Pulled the brake light assembly from cab. Resealed. No longer an issue. Now my issue is this. (I don't know if it is related or not) My cab light/power windows/wipers are not working when they feel like it. I have checked the fuse and housing the fuse is good and housing seems secure. I am thinking I have a ground issue (from leaking brake light). The power windows, dome light, electronic shift and a couple of other things are all linked to the same 10Amp fuse. I took apart the dome light and checked all the wiring I could get at, all seems ok up there! I took apart the door panel that has the electrics mounted to it. My power mirrors are ok, electric door lock ok, power window block looks good. The windows and dome light like I said work when they want to work. I also have another issue, I don't know if it is related or not. My windshield wipers also have decided that they will only work when they want. Not good for driving down the road in a rainstorm. Any help to solve either of these issues would be most appreciated. Thank you!

    Ok, so an update on my issues. I have checked all the grounds under the hood all are good! Went out and got a new wiper motor and I still have the same problem with the wipers working only when they want! Need some advice here anyone please!
     
    Last edited: May 3, 2017
  2. Ranger Forum Sign Up!

    Join RangerForum.com Today - It's Totally Free!

    Are you a Ford Ranger fan? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Ford Ranger Fans to meet online.
    Once you join you'll be able to post messages, upload pictures of your Ford, and have a great time with other Ranger fans. Whether your an old timer or just bought your Ford you'll find that Ranger Forum is a great community to join. Best of all it's totally free!

    Join RnagerForum.com Today! JOIN FOR FREE

  3. OP
    Chuck Moore

    Chuck Moore New Member

    There must be someone in this forum that has some idea of what is causing my problems?
     
  4. Nathan

    Nathan Administrator Staff Member

    Welcome to Ranger Forum Chuck. I'm sure someone will chime in soon.
     
  5. Jon

    Jon Administrator

    Given that the problem is intermittent, have you checked the wires running from the fuse box to the wipers. seems like you would have a lose connection/wire in that run.
     
  6. OP
    Chuck Moore

    Chuck Moore New Member

    yes, i registered! Well my problem has been solved! As it turned out it was my Generic Electronic Module (GEM). I scavenged a GEM that was not actually made for my truck. hooked up the wiring to it. Low and behold my electric windows and dome light now worked perfectly. However my wipers came on and would not stop until I shut the truck off. Literally none of the settings for the wipers worked except for continually being on, no intermittent, no slow and only on fast! My inexpert diagnosis was GEM was messed up. Went out and found a module with the right model number except for the extention of DD instead of DC. I installed it, and now everything works perfectly. Took my Ranger for a test drive and everything appears to be functioning properly. (not completely sure what all is controlled by the GEM). Issue is no longer an issue!!!! Now on to my next problem. My heat and A/C. A/C only gets cold on Max A/C setting. Hot air on all other settings regardless of where the hot cold dial is set! While I wait to see if anyone has any suggestions I will be going to town on this problem. LOL.
     
  7. Jon

    Jon Administrator

    Congrats on getting the electrical problem figured out. Must have felt pretty good to get that taken care of!
     

Share This Page