Idle and cylinder 4 problem help please!

Discussion in '4.0 Engine' started by Joey, Jan 11, 2015.

  1. Joey

    Joey New Member

    first time posting here but i really need help, ive bought an 02 ranger, 4L v6 and shortly after the check engine light came on with a cylinder #4 and 5 misfire and a really rough idle while stopped or at low rpm and higher speeds and rpm the truck seems to be good, so i thought may have been a vacuum leak or something to do with the fuel system, so i checked:

    intake manifold put new gaskets in
    vacuum leak test
    injectors checked
    new plugs
    checked spark
    checked compression
    spark plug cables
    coil pack and plugs
    cleaned the iac
    took the valve cover off everything seemed normal

    any feedback or info would be greatly appreciated, i know i can't be the only person with this problem!
  2. Ranger Forum Sign Up!

    Join Today - It's Totally Free!

    Are you a Ford Ranger fan? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Ford Ranger Fans to meet online.
    Once you join you'll be able to post messages, upload pictures of your Ford, and have a great time with other Ranger fans. Whether your an old timer or just bought your Ford you'll find that Ranger Forum is a great community to join. Best of all it's totally free!

    Join Today! JOIN FOR FREE

  3. gasdon

    gasdon New Member

    Mass flow sensor, change it..

    Sent from my iPhone using Tapatalk

Share This Page