Getting fuel but won't start

Discussion in '2.3 Engine' started by Brandon Powers, Jan 10, 2015.

  1. Brandon Powers

    Brandon Powers New Member

    So a few months back I was driving along in my ranger. Suddenly when I pushed the gas pedal I was getting no power nothing. The engine ran for a couple hundred more feet until I coasted to a stop and it died. Wouldn't start back up. Haven't had the time or the money to mess with it until today. I am getting fuel at the pressure port when the key is turned over. But nothing. The engine will not start. Switched out the relays and still nothing. Not sure where to go from here. Any help is appreciated. Thanks!
  2. Ranger Forum Sign Up!

    Join Today - It's Totally Free!

    Are you a Ford Ranger fan? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Ford Ranger Fans to meet online.
    Once you join you'll be able to post messages, upload pictures of your Ford, and have a great time with other Ranger fans. Whether your an old timer or just bought your Ford you'll find that Ranger Forum is a great community to join. Best of all it's totally free!

    Join Today! JOIN FOR FREE

  3. OP
    Brandon Powers

    Brandon Powers New Member

    Just an small update. The check engine light goes off when the key is turned over and the engine is trying to start. Does not stay lit. I'm getting the correct power to my injectors and coil (steady light and pulse). I'm at a complete loss as to why this damn thing will not turn over.'s a 98...HA!


    Did this ever get figured out? I am having a similar issue but noticed a bit of oil mixed in as well. I have no oil pressure or fuel pressure it seems and the gas is leaking pretty heavily when I try and start.

    The fuel pump is about 2 years old
    Oil was changed days ago
    Plugs/wires were changed maybe 7 months ago

    '90 Ranger XLT

Share This Page