charing problem

Discussion in '2.3 Engine' started by MsFordfan, Sep 17, 2011.

  1. MsFordfan

    MsFordfan 1997 RangerXLT

    Tested alternator...that tested ok
    Tested battery that tested at 12.4 v
    Changed wiring harness from battery to alternator
    Cleaned battery posts
    Still will NOT charge battery
    What next????? Someone suggested brushes inside alternator? Can the system test ok and still have bad brushes?
  2. Ranger Forum Sign Up!

    Join Today - It's Totally Free!

    Are you a Ford Ranger fan? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Ford Ranger Fans to meet online.
    Once you join you'll be able to post messages, upload pictures of your Ford, and have a great time with other Ranger fans. Whether your an old timer or just bought your Ford you'll find that Ranger Forum is a great community to join. Best of all it's totally free!

    Join Today! JOIN FOR FREE

  3. klinger86

    klinger86 Moderator

    i dont think it can.... but i have been wrong before.... but i have had them tell me a battery was good that wasnt...
  4. OP

    MsFordfan 1997 RangerXLT

    Not gonna believe this but we got it fixed.......... was a 15 cent fuse on the panel...looked good but was fried... changed it out and works great.
  5. rango88

    rango88 Chuck Norris Drove a Ram

    glad it was a cheap fix after you already replaced everything :p
  6. Hurley

    Hurley Superultramegalurker

    Nice. Happy to hear it was an easy fix

Share This Page