4WD not working

Discussion in '1998 - 2011 Ford Ranger' started by CV Ranger, Oct 19, 2013.

  1. CV Ranger

    CV Ranger New Member

    Ok when i go to turn on my 4WD high or low it does not come on but if i leave it in 4wd high and turn the truck off come in a hour or two it turn it on but it still not in 4wd drive now its say 4wd high is on but when i try to switch it in 4 low it does want to switch but when i switch it in 2wd it will switch Please help and for some reason my 4WD high and low are flashing on my dash with i turn my truck on please help need info.
  2. Ranger Forum Sign Up!

    Join RangerForum.com Today - It's Totally Free!

    Are you a Ford Ranger fan? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Ford Ranger Fans to meet online.
    Once you join you'll be able to post messages, upload pictures of your Ford, and have a great time with other Ranger fans. Whether your an old timer or just bought your Ford you'll find that Ranger Forum is a great community to join. Best of all it's totally free!

    Join RnagerForum.com Today! JOIN FOR FREE

  3. Fx4wannabe01

    Fx4wannabe01 New Member

    GOOD LORD that was hard to read. Please try that again...

    Could this be a simple user error thing? To shift into LOW, trans must either be in neutral or park(if manual, jiggling of the shifter helps), brake must be pressed, truck cannot be moving. Same for shifting out of LOW.

Share This Page