1997 Cluster question

Discussion in '1993 - 1997 Ford Ranger' started by Brinker88, Dec 25, 2011.

  1. Brinker88

    Brinker88 Black sheep o' the family

    Quick question for you electrical nerds out there. My gauge cluster's messed up and doesnt have a tach.

    If I purchase a new cluster with a tach, is there any wiring I would have to do that isnt plug and play?
  2. Ranger Forum Sign Up!

    Join RangerForum.com Today - It's Totally Free!

    Are you a Ford Ranger fan? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Ford Ranger Fans to meet online.
    Once you join you'll be able to post messages, upload pictures of your Ford, and have a great time with other Ranger fans. Whether your an old timer or just bought your Ford you'll find that Ranger Forum is a great community to join. Best of all it's totally free!

    Join RnagerForum.com Today! JOIN FOR FREE

  3. djfllmn

    djfllmn ^^^ I am Mr. Clean!

    i think it should be plug and play as long as you have the output on the coil for a tach readout
  4. buggman

    buggman Do not touch the trim!

    X2, I think it should be plug-n-play.
    You could probably just swap your speed-o pod in the new cluster to keep your mileage correct... that is, if your speed-o is working properly.
  5. OP

    Brinker88 Black sheep o' the family

    Speedo only goes up to 55 then stops and the gas gauge doesnt work. As for the mileage I really dont give a **** since there's already a different engine in it.
  6. SalRanger2

    SalRanger2 Ranger Lover

    i think it should be just plug and play, ik mine should be and i think 95-03 has the same dash style. not 100% on that but
  7. redrocket

    redrocket New and loving it

    i thank he has to stay around the same year cluster there was something about people with older trucks swaping in like 03 model clusters and their temp gauge not working are something
  8. pooleo

    pooleo New Member

    pnp. 95-97. 98+ lost the resistor on the temp gauge. So you need to swap gauges or take the resistor off, it just slides up and off. A couple cluster lights are different. Like the door ajar will light inplace of the check guage light. I think there is a fuel reset that will show for check guage
  9. DeanKelly

    DeanKelly Member

    I just did the same with my 96. The donor was a 96 explorer with a 4.0. I pinned out each connector on paper and all were the same, plug and play. Tach works perfectly with my 2.3. I verified the tach with PCMScan. I changed the speedo out to keep the mileage. All other guages and lights work with the same sensitivity as the original cluster. Speedo is off by 13% due to the rear suspension change but a new gear will fix that next week.
  10. OP

    Brinker88 Black sheep o' the family

    Yea I just plugged it in and it works wonderfully. Thanks tho.

Share This Page