1994 Ford Ranger

Discussion in 'General Discussion' started by Rusty, Aug 8, 2017.

  1. Rusty

    Rusty New Member

    Having issues with rough idling....changed spark plugs and wires plus fuel filter. Smells of gas coming out of exhaust. Wondering if it might possibly be the O2 sensor or MAP Sensor? Where are these located also?
     
  2. Ranger Forum Sign Up!

    Join RangerForum.com Today - It's Totally Free!

    Are you a Ford Ranger fan? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Ford Ranger Fans to meet online.
    Once you join you'll be able to post messages, upload pictures of your Ford, and have a great time with other Ranger fans. Whether your an old timer or just bought your Ford you'll find that Ranger Forum is a great community to join. Best of all it's totally free!

    Join RnagerForum.com Today! JOIN FOR FREE

  3. Dchad53

    Dchad53 Member

    Map sensor is near the end of the air inlet hose leading to the air box.
     
  4. OP
    Rusty

    Rusty New Member

    Thanks David...do you happen to have a diagram or pic?
     
  5. Dchad53

    Dchad53 Member

    Try YOU TUBE. they have tons of how to articles.
     
  6. OP
    Rusty

    Rusty New Member

    Thanks
     
  7. ZappyBear

    ZappyBear New Member

    Faulty O2 sensor would cause it to run rich if it hasn't set a code. If the '94 is anything like the '93, check the fuel pressure regulator, mine had a ruptured diaphram and was sucking unmetered gas into the intake.
     
    Rusty likes this.
  8. OP
    Rusty

    Rusty New Member

    Thank you ZappyBear....I will check that out!!
     

Share This Page