1993 Ranger 4.0 V6 with hesitation until full throttle

Discussion in '1993 - 1997 Ford Ranger' started by BlakeryBob03, Aug 5, 2009.

  1. BlakeryBob03

    BlakeryBob03 New Member

    I have a 93 ranger 4.0 and I am having problems with hesitation during acceleration. The truck idles fine, but when i start to accelerate, it will hesitate until I goose the throttle all the way and then it takes off and starts running great. I have recently changed the plugs, wires, fuel filter, pcv valve and air filter. Someone has suggested to me it could be a loose wire at the battery, coil packs, egr valve, or a dirty MAF sensor... Does anyone have any advice for me?
  2. Ranger Forum Sign Up!

    Join RangerForum.com Today - It's Totally Free!

    Are you a Ford Ranger fan? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Ford Ranger Fans to meet online.
    Once you join you'll be able to post messages, upload pictures of your Ford, and have a great time with other Ranger fans. Whether your an old timer or just bought your Ford you'll find that Ranger Forum is a great community to join. Best of all it's totally free!

    Join RnagerForum.com Today! JOIN FOR FREE

  3. Bill

    Bill New Member

    Remove the TPS and test it with an ohm meter. Meter should sweep smoothly through out its range. The TPS tells the PCM (powertrain control module) what you, as the driver are doing to the engine.
  4. ugaboychevylover

    ugaboychevylover New Member

    sounds stupid but check your air intake could have small hole in it somewhere after the mass air sensor i had to make a cold air intake c ause of one i know put ducktape can fix it really check it out buddy:yes:

Share This Page