Discussion in 'Drivetrain Tech' started by greenmachine2000, Oct 16, 2012.

  1. greenmachine2000

    greenmachine2000 New Member

    getting what feels to be a front ennd vibration after 50 mph..fasster the more vibration..recent allignment and anyone know?..all occoured after engaging and dissengaging 4lo
  2. Ranger Forum Sign Up!

    Join Today - It's Totally Free!

    Are you a Ford Ranger fan? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Ford Ranger Fans to meet online.
    Once you join you'll be able to post messages, upload pictures of your Ford, and have a great time with other Ranger fans. Whether your an old timer or just bought your Ford you'll find that Ranger Forum is a great community to join. Best of all it's totally free!

    Join Today! JOIN FOR FREE

  3. Scrambler82

    Scrambler82 Old Guy User

    First thought, did 4 L disengage completely.

    Attempt to back up while turning the wheels for a sharp turn.
    If things start to bind up then you are still in 4 WD.

    If not check for wheel weights that have fallen off larger tire usually need additional weights to balance properly and they may have fallen off, also check the front end components and see if anything is moving a little too much.
  4. Hooligan

    Hooligan Rangerholic!!

    ^^ This. Sometimes the wheel weights WILL fly off after a fresh balance. The "tap" on weights have a tendency to fly off with bigger tires. If they put sticky weights on, double check them. Some shops won't clean the inner part of the rim and will slap on the sticky a corroded surface.....then, they fly off. The issue definitly sounds like a balance issue to me.
  5. DPG3

    DPG3 Member

    maybe a bad bushing on the suspension. or a bent control arm. you never know till you inspect it.
  6. klinger86

    klinger86 Moderator

    i would say take it back and have them rebalance the wheels....
  7. OP

    greenmachine2000 New Member

    ill do that..had my iacv take a **** cleaned it..thinking about cleaning inside intake system more...bad or good idea??
  8. Scrambler82

    Scrambler82 Old Guy User

    If the truck is running ok leave it be !

    Fix the vibration first.
  9. kdiggy

    kdiggy OSCAR

    Also check your u joints they may have no play but could still have 1 or all bad:yes:

Share This Page