No fire Ranger

Discussion in '1989 - 1992 Ford Ranger' started by jrwhiteman, Aug 18, 2012.

  1. jrwhiteman

    jrwhiteman New Member

    Okay so I got a 1989 ford ranger 2.9L Automatic, lost it's fire so I checked the coil, no fire. took a good coil out of my parts truck and put it in my driver, still no fire comming off the coil. Tried both coils and coil wires in my parts truck and both work fine in the parts truck. Cecked all fuses and relays they all appear to be good. What would cause the coil to work in one truck but not the other, looking for Ideas of what to check next. could it be the ignition switch? how would I check that? Also I took the distributor cap off and watch to make sure the rotor button goes around and it does, haven't checked ecm yet that will be next, anyways anyone got any ideas? anything will help and be appreciated
  2. Ranger Forum Sign Up!

    Join Today - It's Totally Free!

    Are you a Ford Ranger fan? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Ford Ranger Fans to meet online.
    Once you join you'll be able to post messages, upload pictures of your Ford, and have a great time with other Ranger fans. Whether your an old timer or just bought your Ford you'll find that Ranger Forum is a great community to join. Best of all it's totally free!

    Join Today! JOIN FOR FREE

  3. djfllmn

    djfllmn ^^^ I am Mr. Clean!

    crank position sensor, cam position sensor
  4. pooleo

    pooleo New Member

    Not sure what that old guy uses for its signal to the coil. Some how, the crank spins and generates electricity and it gets sent to the coil. Just back track until you find the source.

Share This Page