Idles fine, won't rev

Discussion in '1993 - 1997 Ford Ranger' started by ZappyBear, Dec 27, 2018.

  1. ZappyBear

    ZappyBear Member

    I've got an issue I'm about to give up on. I got a "new to me" 1994 4.0l. Alot of you will probably remember the thread I made on it. Well, it now idles just fine, will start up, but if you try to drive it, it'll attempt to stall like it's running too lean. I've tried unplugging the MAF and running it, I've also tried TPS, new upper intake gasket, unhooking and plugging the vacuum lines on the vacuum tree. It got new plugs and wires as I do with every old vehicle I buy. While doing the upper intake gasket I checked the injectors and all appear to work properly. It's got a new fuel pump assembly and new fuel filter. If I unplug the MAF and try to drive it, then park it, It'll make popping noises from the exhaust and flames will come out of the cat. (Currently the exhaust is unhooked up to the cat) I also pulled out an oxygen sensor just to see if the cat was partly plugged. I have yet to but a code reader and run a KOER test. Fuel pressure tested out just fine, It's also got a missfire as heard in the exhaust.
     
  2. Ranger Forum Sign Up!

    Join RangerForum.com Today - It's Totally Free!

    Are you a Ford Ranger fan? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Ford Ranger Fans to meet online.
    Once you join you'll be able to post messages, upload pictures of your Ford, and have a great time with other Ranger fans. Whether your an old timer or just bought your Ford you'll find that Ranger Forum is a great community to join. Best of all it's totally free!

    Join RnagerForum.com Today! JOIN FOR FREE

  3. OP
    ZappyBear

    ZappyBear Member

    I took the intake to find the injectors clogged. I ordered 6 new ones as the metal casing was almost rotted out. I'm guessing it's gunk from the old gas. Anyone got any idea on making sure this gunk won't get into the new injectors if any remains in the system?
     
  4. OP
    ZappyBear

    ZappyBear Member

    Well, it's been too long since an update. Injectors didn't solve the issue. It's really strange, it hit the rev limiter when I first replaced the pump assembly but now it just sputters out and backfires when I hit the gas. What changed over time? The fuel pressure comes out fine at idle and when it's sputtering and backfiring. I don't think it could be a fuel quantity issue? Don't you need fuel quantity to get pressure and a lack of quantity would result in decreasing pressure as I hit the throttle?
     
  5. Joedaddy

    Joedaddy New Member

    I’ve had the same thing happen wouldn’t throw a code on the 2.3 it turned out to be crankshaft sensor
     
  6. OP
    ZappyBear

    ZappyBear Member

    Well, I found my own Solution. After replacing everything EXCLUDING TPS, crank sensor, and computer. It turned out to be 2 plug wires swapped around. And the misfire went away. Things that should have pointed to this was lean appearance on plugs on all cylinder excluding 2, the 2 cylinders not firing were oil fouled, "bumping" of the starter like it had a dead spot, cylinder may have been firing part way through exhaust stroke which explains the flames out the exhaust under special conditions. Luckily it didn't blow the piston out the oil pan.
     
    Last edited: Mar 1, 2019

Share This Page