fduel system problems

Discussion in 'General Discussion' started by 88dangerranger, Jul 5, 2011.

  1. 88dangerranger

    88dangerranger New Member

    hey yall i am new to this site and was wondering if one of u guys could help me out. I have a 1988 ford ranger 4x4 has the 2.9 electronic fuel injected motor in it. My problem is that i put a new fuel pump in the gas tank and a new filter on the frame rail and it isnt getting enough fuel pressure to fire up my truck i had it fired up twice so far but it blew the lines in two places i replaced the sections of lines and now it will not start at all what could be the problem. If some one could help me out i would greatly appreciate it . Thank you
  2. Ranger Forum Sign Up!

    Join RangerForum.com Today - It's Totally Free!

    Are you a Ford Ranger fan? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Ford Ranger Fans to meet online.
    Once you join you'll be able to post messages, upload pictures of your Ford, and have a great time with other Ranger fans. Whether your an old timer or just bought your Ford you'll find that Ranger Forum is a great community to join. Best of all it's totally free!

    Join RnagerForum.com Today! JOIN FOR FREE

  3. that sounds like a fuel pump issue, if new have the store replace it under warranty, but what a " PITA", filter on in right direction?
  4. OP

    88dangerranger New Member

    that is what i thought at first but i can hear it humming and also when i put the new one in and tried to fire it up it blew one of the lines so i replace it now it isnt getting fuel pressure i think it is the fuel pressure regulator. could that be the problem?
  5. klinger86

    klinger86 Moderator

    sounds to me like it's either the regulator or some junk in the fuel lines....

Share This Page