brake problems..going mad!!!

Discussion in 'General Discussion' started by Joe.V, Nov 25, 2013.

  1. Joe.V

    Joe.V New Member

    I'v been having problems with my brakes for a little while now. problem is when coming to a stop the brake pedal gives and the abs kicks on, and there is a noise that goes along with it it. Its a 99 ford xlt. I have changed brakes, rotors, passanger side hub assembley with sensor. going to do the driver side tomorrow. Can someone please help me give me an answere what the problem can be. Hub assembleys are alot of money.

    Thanks Joe.V
  2. Ranger Forum Sign Up!

    Join Today - It's Totally Free!

    Are you a Ford Ranger fan? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Ford Ranger Fans to meet online.
    Once you join you'll be able to post messages, upload pictures of your Ford, and have a great time with other Ranger fans. Whether your an old timer or just bought your Ford you'll find that Ranger Forum is a great community to join. Best of all it's totally free!

    Join Today! JOIN FOR FREE


    LILFOOT New Member

    Is this happening under light braking, low speed ?

    Sent from my Ocular Implantâ„¢
  4. OP

    Joe.V New Member

    hey thanks for the reply! i actually put a new hub on the driver side and i fixed it. it was real expensive but east to put in. it was happening at low speed, coming to a stop. thanks again.

Share This Page