2009 rusted bed mounts

Discussion in '1998 - 2011 Ford Ranger' started by Rickyranger, Feb 16, 2018.

  1. Rickyranger

    Rickyranger New Member

    2009 bed mounts rusted away and broke ...yes a clean 2009..iv never seen such junk in my life..iv owned 7 rangers from 1984 on up never bad metal like this .I'm a ranger only guy never another Ford..bad junk Chinese metal.box mounts rusted off also around radiator area very bad ..no exterior rust at all very discouraging ..this truck is 8 years old box falls off frame..
  2. Ranger Forum Sign Up!

    Join RangerForum.com Today - It's Totally Free!

    Are you a Ford Ranger fan? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Ford Ranger Fans to meet online.
    Once you join you'll be able to post messages, upload pictures of your Ford, and have a great time with other Ranger fans. Whether your an old timer or just bought your Ford you'll find that Ranger Forum is a great community to join. Best of all it's totally free!

    Join RnagerForum.com Today! JOIN FOR FREE

  3. mhoward

    mhoward Member

    Hello Rick and welcome to the forum. Not sure what to say about the rust. For whatever reason, Ford chose to NOT paint a lot of exposed metal under the Ranger. If it wasn't seen, it wasn't painted. Best you can do is fabricate some new bed mounts, clean everything up best you can and give it all a good coat of anti-rust coating. Good luck!

Share This Page