1993 - Engine Dies When Clutch Engaged

Discussion in 'General Discussion' started by Jerry108, Apr 29, 2013.

  1. Jerry108

    Jerry108 New Member

    I have a 1993 Ranger whose engine dies as soon as the clutch pedal is released...even in neutral...even with the engine revved up.

    Starts fine and the engine runs fine with my foot on the clutch pedal, even with high RPM.

    Dies immediately upon release.

    Six months prior to this problem it had the following maintenance: new clutch, new fuel pump/filter, new gas line filter, new plugs and wires, gas tank removed and cleaned out (truck sat unused for years).

    About a month ago it was hard to shift. Replacing low clutch fluid fixed that problem and all of a sudden this problem started without any other symptoms.

    I've spent way more than I wanted to to get it running again and would like to narrow down the possibilities before it breaks the bank.

    Thanks for your help.
  2. Ranger Forum Sign Up!

    Join RangerForum.com Today - It's Totally Free!

    Are you a Ford Ranger fan? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Ford Ranger Fans to meet online.
    Once you join you'll be able to post messages, upload pictures of your Ford, and have a great time with other Ranger fans. Whether your an old timer or just bought your Ford you'll find that Ranger Forum is a great community to join. Best of all it's totally free!

    Join RnagerForum.com Today! JOIN FOR FREE

  3. djfllmn

    djfllmn ^^^ I am Mr. Clean!

    replace the slave cylinder when you did the clutch?

Share This Page